HELP CENTER

<iOS> What models of iPhone, iPad and iPod touch do I need for using KineMaster?

Follow

KineMaster for iOS

KineMaster requires iOS 10.0 or later, with a 64-bit (A7 or later) processor. KineMaster supports the following iPhone, iPad, and iPod touch models:

 

  • iPhone
    • iPhone 5S
    • iPhone 6, 6 Plus
    • iPhone 6S, 6S Plus *
    • iPhone SE *
    • iPhone 7, 7 Plus *
    • iPhone 8, 8 Plus *
    • iPhone X *
    • iPhone XS, XS Max *
    • iPhone XR *
  • iPad (9.7-inch)
    • iPad Air
    • iPad Air 2
    • iPad (2017)
    • iPad (2018)
  • iPad Mini (7.9-inch)
    • iPad mini 2
    • iPad mini 3
    • iPad mini 4
  • iPad Pro
    • 12.9-inch iPad Pro
    • 9.7-inch iPad Pro *
    • 12.9-inch iPad Pro (2nd Generation) *
    • 10.5-inch iPad Pro *
    • 12.9-inch iPad Pro (3rd Generation) *
    • 11-inch iPad Pro *
  • iPod touch
    • iPod touch (6th Generation)

 

* : supports 4k exporting.

 

Note:

  1. KineMaster does not support iPhone 5c.
Have more questions? Submit a request